Page 1 of 1

Cartridge won't feed into Chamber

PostPosted: Mon Sep 20, 2010 4:35 pm
by punkin77
I own a Taurus PT22/25. It fires one bullet nice and smoothly, but it will not feed another into the chamber. It is new and has only been shot a few times.



Any suggestions??

PostPosted: Mon Sep 20, 2010 5:33 pm
by tigwelder56
There are a few thoughts that come to mind. First, have you tried a different magazine? Second, you need to try several different brands of ammo and design. Some hollowpoints won't feed but round nose will. That happens all the time with rimfire semi autos. Third, you should polish the feed ramp till it shines. You can find do it yourself ideas all over, just Google it. If you don't want to attempt it yourself, take it to a gunsmith. It won't cost you much and they'll do a great job.

PostPosted: Thu Sep 23, 2010 7:56 am
by agonist
Which is it, PT22 or PT25?

PostPosted: Thu Sep 30, 2010 11:06 pm
by Mik3e
If the slide rails don't have proper lubrication the energy generated by the round can't overcome the friction and properly cycle the slide and feed the next round. I'd try it once sloppy with oil/grease just to make sure something this simple isn't the problem.

PostPosted: Fri Oct 01, 2010 9:44 am
by punkin77
It is a PT22 and Taurus did send me a 2nd magazine - having the same problem.



Taurus sent FedEx to pick it up and said they would have it back in 3 weeks - and that it is under warranty.



At least I an getting a good response from the company.